summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c6c80c7..1690702 100755
--- a/setup.py
+++ b/setup.py
@@ -16,6 +16,11 @@ class install_pylock(distutils.command.install.install):
distutils.core.setup(
name = 'pylock',
version = '1',
+ author = 'Matthias Schiffer',
+ author_email = 'mschiffer@universe-factory.net',
+ url = 'http://git.universe-factory.net/pylock/',
+ description = 'A lightweight screenlocker for X implemented in Python 3 using Gtk3',
+ license = 'BSD',
packages = ['pylock'],
package_data = {
@@ -29,4 +34,13 @@ distutils.core.setup(
'build_i18n': build_i18n.build_i18n,
'install': install_pylock,
},
+
+ provides = ['pylock'],
+ requires = [
+ 'gi.repository.Gtk',
+ 'gi.repository.Gdk',
+ 'gi.repository.GdkX11',
+ 'gi.repository.GObject',
+ 'gi.repository.GLib',
+ ],
)