summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-10-25 00:19:45 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-10-25 00:19:45 +0200
commit34ac18d20c13a78914d447fee83204811a27b1e4 (patch)
tree56763d4ea46927105fcc6a71e03d5bd75a6947a6 /Cargo.toml
parenta1a185370da27f2cc3df84d3a8d7141f9ce7db16 (diff)
downloadrebel-34ac18d20c13a78914d447fee83204811a27b1e4.tar
rebel-34ac18d20c13a78914d447fee83204811a27b1e4.zip
Move runner into separate crate
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 1 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6024b79..921d917 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,26 +11,18 @@ edition = "2018"
[dependencies]
common = { path = "crates/common", package = "rebel-common" }
+runner = { path = "crates/runner", package = "rebel-runner" }
-blake3 = { version = "1.0.0", features = ["traits-preview"] }
-capctl = "0.2.0"
clap = "3.0.0-beta.2"
-digest = "0.9.0"
enum-kinds = "0.5.1"
handlebars = "4.1.3"
indoc = "1.0.3"
ipc-channel = { git = "https://github.com/servo/ipc-channel.git" }
lazy_static = "1.4.0"
-libc = "0.2.84"
-nix = "0.23.0"
-olpc-cjson = "0.1.0"
regex = "1.5.4"
scoped-tls-hkt = "0.1.2"
serde = { version = "1", features = ["derive"] }
-serde_json = "1.0.62"
serde_yaml = "0.8"
-tar = "0.4.32"
-tee_readwrite = "0.1.0"
walkdir = "2"
[profile.dev.package."*"]