summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-10-08 22:08:40 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-10-08 22:08:40 +0200
commit671e3fd3abbc5d6aec903c4a88ef0e037af6fe8a (patch)
treecaa44d37cf5f497b2c128be97d5b702fe7e79072 /Cargo.toml
parent296295d1aa6684dd12cfd95c28004d539dfa315f (diff)
downloadrebel-671e3fd3abbc5d6aec903c4a88ef0e037af6fe8a.tar
rebel-671e3fd3abbc5d6aec903c4a88ef0e037af6fe8a.zip
Switch from SHA256 to Blake3 for task hashes
Mostly relevant for output hashing, and the to-be-implemented workdir hashing. Passing data to the hasher is not optimized using a buffered writer yet.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b1cb651..3b982d1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,7 +8,9 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+blake3 = { version = "1.0.0", features = ["traits-preview"] }
clap = "3.0.0-beta.2"
+digest = "0.9.0"
enum-kinds = "0.5.1"
handlebars = "4.1.3"
hex = { version = "0.4.3", features = ["std", "serde"] }
@@ -23,7 +25,6 @@ scoped-tls-hkt = "0.1.2"
serde = { version = "1", features = ["derive"] }
serde_json = "1.0.62"
serde_yaml = "0.8"
-sha2 = "0.9.5"
tar = "0.4.32"
tee_readwrite = "0.1.0"
users = "0.11.0"