summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-10-24 22:40:08 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-10-24 23:58:03 +0200
commita1a185370da27f2cc3df84d3a8d7141f9ce7db16 (patch)
tree6904f6f0549e89d160cbe635713e2864df25c21a /Cargo.toml
parent524985f9449eb2f3a1d01b5f88dc74123d40c43a (diff)
downloadrebel-a1a185370da27f2cc3df84d3a8d7141f9ce7db16.tar
rebel-a1a185370da27f2cc3df84d3a8d7141f9ce7db16.zip
Split defintions used by both runner and executor into separate crate
Also get rid of the Runner trait - different runner implementations do not make sense with our current design.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 25b2105..6024b79 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,14 +7,17 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[workspace]
+
[dependencies]
+common = { path = "crates/common", package = "rebel-common" }
+
blake3 = { version = "1.0.0", features = ["traits-preview"] }
capctl = "0.2.0"
clap = "3.0.0-beta.2"
digest = "0.9.0"
enum-kinds = "0.5.1"
handlebars = "4.1.3"
-hex = { version = "0.4.3", features = ["std", "serde"] }
indoc = "1.0.3"
ipc-channel = { git = "https://github.com/servo/ipc-channel.git" }
lazy_static = "1.4.0"