summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-09-06 01:15:19 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-09-06 01:15:19 +0200
commita29b5f808d39cacd6981276015603aa68afdbc1e (patch)
tree5e047d39b57db095ad23f2cfa6bec5c784ffa153 /Cargo.toml
parent339942b8fc3ba3a4300a0cab8adf00610255c8c2 (diff)
downloadrebel-a29b5f808d39cacd6981276015603aa68afdbc1e.tar
rebel-a29b5f808d39cacd6981276015603aa68afdbc1e.zip
Use rm_rf crate instead of remove_dir_all()
remove_dir_all() fails to delete overlayfs directories due to missing permissions.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 25adbd8..b610c6a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,6 +15,7 @@ libc = "0.2.84"
nix = "0.22.0"
oci-spec = "0.4.0"
olpc-cjson = "0.1.0"
+rm_rf = "0.6.1"
serde = { version = "1", features = ["derive"] }
serde_json = "1.0.62"
serde_yaml = "0.8"