summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-01-31 19:18:20 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-01-31 19:18:20 +0100
commitb9e28bd7990b597d707fb9a81880dc14accc9c41 (patch)
treefbb54d67bac841728450b62cd192095b9d3993b5 /Cargo.toml
parent6eb0851420b358132dd8a72312b25a1f7efd02de (diff)
downloadrebel-b9e28bd7990b597d707fb9a81880dc14accc9c41.tar
rebel-b9e28bd7990b597d707fb9a81880dc14accc9c41.zip
Unshare/subuid handling
Buildah is too slow for our usecase. Handle userns setup ourselves, so we can call runc directly.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 820a5fa..480d584 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,7 +7,10 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+libc = "0.2.84"
+nix = "0.19.1"
scopeguard = "1.1.0"
serde = { version = "1", features = ["derive"] }
serde_yaml = "0.8"
+users = "0.11.0"
walkdir = "2"