summaryrefslogtreecommitdiffstats
path: root/crates/driver/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2024-04-03 21:43:46 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2024-04-03 22:31:14 +0200
commit142ab0db2902a42b1c11f9682d366a5c7750c649 (patch)
treef090807ba019a31ad963246159c3cd1b8cc842d1 /crates/driver/Cargo.toml
parent42e667a5086fa4a6557ef7a64e40b833a93f3124 (diff)
downloadrebel-142ab0db2902a42b1c11f9682d366a5c7750c649.tar
rebel-142ab0db2902a42b1c11f9682d366a5c7750c649.zip
driver: parse: replace nom with peg
The PEG-based parser is much more concise and easier to understand than the old combinator solution.
Diffstat (limited to 'crates/driver/Cargo.toml')
-rw-r--r--crates/driver/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/driver/Cargo.toml b/crates/driver/Cargo.toml
index 683ebbe..673e0ba 100644
--- a/crates/driver/Cargo.toml
+++ b/crates/driver/Cargo.toml
@@ -18,8 +18,8 @@ handlebars = "5.1.2"
indoc = "2.0.4"
lazy_static = "1.4.0"
nix = { version = "0.28.0", features = ["poll"] }
-nom = "7.1.0"
scoped-tls-hkt = "0.1.2"
serde = { version = "1", features = ["derive", "rc"] }
serde_yaml = "0.9"
walkdir = "2"
+peg = "0.8.2"