summaryrefslogtreecommitdiffstats
path: root/crates/driver/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-11-05 17:02:26 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-11-05 17:02:26 +0100
commit1671d0fbf3b5691f2db44883a0973ec858beaf94 (patch)
tree25120d00b54a443acdeaeb3ec9352cfc88c8d8ee /crates/driver/Cargo.toml
parent3bfca7703c298e3379fde398ea71b5cf082ba5bf (diff)
downloadrebel-1671d0fbf3b5691f2db44883a0973ec858beaf94.tar
rebel-1671d0fbf3b5691f2db44883a0973ec858beaf94.zip
driver: replace regex with nom-based parser
For now, the nom-based parser doesn't really reduce complexity, but we will need a more powerful parsing solution anyways when the task YML is replaced with a specialized language.
Diffstat (limited to 'crates/driver/Cargo.toml')
-rw-r--r--crates/driver/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/driver/Cargo.toml b/crates/driver/Cargo.toml
index 36afe9f..9913a83 100644
--- a/crates/driver/Cargo.toml
+++ b/crates/driver/Cargo.toml
@@ -18,7 +18,7 @@ handlebars = "4.1.3"
indoc = "1.0.3"
lazy_static = "1.4.0"
nix = "0.23.0"
-regex = "1.5.4"
+nom = "7.1.0"
scoped-tls-hkt = "0.1.2"
serde = { version = "1", features = ["derive", "rc"] }
serde_yaml = "0.8"