summaryrefslogtreecommitdiffstats
path: root/crates/driver/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2024-04-07 01:10:43 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2024-04-07 01:22:12 +0200
commit1d1a40b55a94c2f3a7477f066035f165e37779e4 (patch)
tree2ca3ca283f15d4dc84b789ef8519e20084ee4938 /crates/driver/Cargo.toml
parentb1f6695e5759d39b711ab599726bc1ae61fcacac (diff)
downloadrebel-1d1a40b55a94c2f3a7477f066035f165e37779e4.tar
rebel-1d1a40b55a94c2f3a7477f066035f165e37779e4.zip
driver: implement "soft" SIGINT handling
On the first SIGINT, spawning new tasks is disabled, but running tasks are allowed to finish. The second SIGINT will terminate the build immediately.
Diffstat (limited to 'crates/driver/Cargo.toml')
-rw-r--r--crates/driver/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/crates/driver/Cargo.toml b/crates/driver/Cargo.toml
index 673e0ba..df1fb19 100644
--- a/crates/driver/Cargo.toml
+++ b/crates/driver/Cargo.toml
@@ -17,7 +17,7 @@ enum-kinds = "0.5.1"
handlebars = "5.1.2"
indoc = "2.0.4"
lazy_static = "1.4.0"
-nix = { version = "0.28.0", features = ["poll"] }
+nix = { version = "0.28.0", features = ["poll", "signal"] }
scoped-tls-hkt = "0.1.2"
serde = { version = "1", features = ["derive", "rc"] }
serde_yaml = "0.9"