summaryrefslogtreecommitdiffstats
path: root/crates/runner/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-10-25 00:19:45 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-10-25 00:19:45 +0200
commit34ac18d20c13a78914d447fee83204811a27b1e4 (patch)
tree56763d4ea46927105fcc6a71e03d5bd75a6947a6 /crates/runner/Cargo.toml
parenta1a185370da27f2cc3df84d3a8d7141f9ce7db16 (diff)
downloadrebel-34ac18d20c13a78914d447fee83204811a27b1e4.tar
rebel-34ac18d20c13a78914d447fee83204811a27b1e4.zip
Move runner into separate crate
Diffstat (limited to 'crates/runner/Cargo.toml')
-rw-r--r--crates/runner/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/crates/runner/Cargo.toml b/crates/runner/Cargo.toml
new file mode 100644
index 0000000..b69e51e
--- /dev/null
+++ b/crates/runner/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "rebel-runner"
+version = "0.1.0"
+authors = ["Matthias Schiffer <mschiffer@universe-factory.net>"]
+license = "MIT"
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+common = { path = "../common", package = "rebel-common" }
+
+blake3 = { version = "1.0.0", features = ["traits-preview"] }
+capctl = "0.2.0"
+digest = "0.9.0"
+ipc-channel = { git = "https://github.com/servo/ipc-channel.git" }
+libc = "0.2.84"
+nix = "0.23.0"
+olpc-cjson = "0.1.0"
+serde = { version = "1", features = ["derive"] }
+serde_json = "1.0.62"
+tar = "0.4.32"
+tee_readwrite = "0.1.0"