summaryrefslogtreecommitdiffstats
path: root/crates/runner/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2021-10-26 18:43:51 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2021-10-26 19:03:17 +0200
commit5d93586e6def88752323d6dc91443a24a5b7e0f0 (patch)
treec2104054006a0b340f23adc3874c22b04d6c1a9e /crates/runner/Cargo.toml
parent8bebe4c76107d8b0a55fda238b0475469d374d77 (diff)
downloadrebel-5d93586e6def88752323d6dc91443a24a5b7e0f0.tar
rebel-5d93586e6def88752323d6dc91443a24a5b7e0f0.zip
Replace ipc-channel with UNIX sockets and manual FD passing
The new implementation is more flexible, as it allows mixed polling with other FD types, and it saves us a whole zoo of dependencies.
Diffstat (limited to 'crates/runner/Cargo.toml')
-rw-r--r--crates/runner/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/crates/runner/Cargo.toml b/crates/runner/Cargo.toml
index 5d51739..d8fe562 100644
--- a/crates/runner/Cargo.toml
+++ b/crates/runner/Cargo.toml
@@ -13,7 +13,6 @@ common = { path = "../common", package = "rebel-common" }
blake3 = { version = "1.0.0", features = ["traits-preview"] }
capctl = "0.2.0"
digest = "0.9.0"
-ipc-channel = { git = "https://github.com/servo/ipc-channel.git" }
libc = "0.2.84"
nix = "0.23.0"
olpc-cjson = "0.1.0"
@@ -21,3 +20,5 @@ serde = { version = "1", features = ["derive"] }
serde_json = "1.0.62"
tar = "0.4.32"
tee_readwrite = "0.1.0"
+uds = "0.2.6"
+bincode = "1.3.3"