summaryrefslogtreecommitdiffstats
path: root/crates/rebel-runner/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/rebel-runner/Cargo.toml')
-rw-r--r--crates/rebel-runner/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/rebel-runner/Cargo.toml b/crates/rebel-runner/Cargo.toml
new file mode 100644
index 0000000..3df06f8
--- /dev/null
+++ b/crates/rebel-runner/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "rebel-runner"
+version = "0.1.0"
+authors = ["Matthias Schiffer <mschiffer@universe-factory.net>"]
+license = "MIT"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+rebel-common = { path = "../rebel-common" }
+
+bincode = "1.3.3"
+blake3 = { version = "1.3.0", features = ["traits-preview"] }
+capctl = "0.2.0"
+digest = "0.10.1"
+libc = "0.2.84"
+nix = { version = "0.28.0", features = ["user", "fs", "process", "mount", "sched", "poll", "signal", "hostname", "resource"] }
+olpc-cjson = "0.1.0"
+serde = { version = "1", features = ["derive"] }
+serde_json = "1.0.62"
+tar = "0.4.32"
+tee_readwrite = "0.2.0"
+uds = "0.4.1"
+walkdir = "2.3.2"