summaryrefslogtreecommitdiffstats
path: root/crates/rebel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/rebel/Cargo.toml')
-rw-r--r--crates/rebel/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/rebel/Cargo.toml b/crates/rebel/Cargo.toml
new file mode 100644
index 0000000..7164ca6
--- /dev/null
+++ b/crates/rebel/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "rebel"
+version = "0.1.0"
+authors = ["Matthias Schiffer <mschiffer@universe-factory.net>"]
+license = "MIT"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+common = { path = "../rebel-common", package = "rebel-common" }
+runner = { path = "../rebel-runner", package = "rebel-runner" }
+
+clap = { version = "4.0.0", features = ["derive"] }
+deb-version = "0.1.1"
+enum-kinds = "0.5.1"
+handlebars = "5.1.2"
+indoc = "2.0.4"
+lazy_static = "1.4.0"
+nix = { version = "0.28.0", features = ["poll", "signal"] }
+scoped-tls-hkt = "0.1.2"
+serde = { version = "1", features = ["derive", "rc"] }
+serde_yaml = "0.9"
+walkdir = "2"
+peg = "0.8.2"