summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-02-01 00:21:17 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-02-01 00:27:01 +0100
commitcbe64618821a0ae9f1901ce1a4a3893d939fdc32 (patch)
tree6a8341bdd90623817c26b2707df98910dd6a9e29 /src/CMakeLists.txt
parent1e74afda41658ad38cbf0bd65847571861237cb5 (diff)
downloadMinedMap-cbe64618821a0ae9f1901ce1a4a3893d939fdc32.tar
MinedMap-cbe64618821a0ae9f1901ce1a4a3893d939fdc32.zip
Implement most of the chunk format
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4559a19..df50419 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,3 +1,12 @@
+include_directories(${ZLIB_INCLUDE_DIRS})
+link_directories(${ZLIB_LIBRARY_DIRS})
+
add_executable(MinedMap
MinedMap.cpp
+ NBT/Tag.cpp
+ World/Chunk.cpp
+ World/Region.cpp
)
+set_target_properties(MinedMap PROPERTIES COMPILE_FLAGS "-std=c++11 -Wall ${ZLIB_CFLAGS_OTHER}")
+set_target_properties(MinedMap PROPERTIES LINK_FLAGS "${ZLIB_LDFLAGS_OTHER}")
+target_link_libraries(MinedMap ${ZLIB_LIBRARIES})