summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Mares <mj@ucw.cz>2000-02-24 19:43:23 +0100
committerMartin Mares <mj@ucw.cz>2000-02-24 19:43:23 +0100
commit1d4ba6583afa5e6d4118aca0d0a645342d575b68 (patch)
tree5d59ef67ee016230efce9328f25bc28b445a2568 /configure.in
parentab56f6b16fd9401565a066122be3231dccd24fb6 (diff)
downloadbird-1d4ba6583afa5e6d4118aca0d0a645342d575b68.tar
bird-1d4ba6583afa5e6d4118aca0d0a645342d575b68.zip
Moan loudly if libreadline is an old version which doesn't support
callbacks.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 579c6bd..b0c3f8d 100644
--- a/configure.in
+++ b/configure.in
@@ -142,8 +142,8 @@ if test "$enable_client" = yes ; then
AC_CHECK_LIB(ncurses, tgetent, USE_TERMCAP_LIB=-lncurses,
AC_CHECK_LIB(curses, tgetent, USE_TERMCAP_LIB=-lcurses,
AC_CHECK_LIB(termcap, tgetent, USE_TERMCAP_LIB=-ltermcap)))
- AC_CHECK_LIB(readline, readline, CLIENT_LIBS="-lreadline $CLIENT_LIBS $USE_TERMCAP_LIB",
- AC_MSG_ERROR([[The client requires GNU readline library. Either install the library or use --disable-client to compile without the client.]]), $USE_TERMCAP_LIB)
+ AC_CHECK_LIB(readline, rl_callback_read_char, CLIENT_LIBS="-lreadline $CLIENT_LIBS $USE_TERMCAP_LIB",
+ AC_MSG_ERROR([[The client requires GNU readline library 4.0 or newer. Either install the library or use --disable-client to compile without the client.]]), $USE_TERMCAP_LIB)
fi
AC_SUBST(CLIENT)
AC_SUBST(CLIENT_LIBS)