summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Mares <mj@ucw.cz>1999-04-12 17:27:56 +0200
committerMartin Mares <mj@ucw.cz>1999-04-12 17:27:56 +0200
commit61fb537c6273c50deb7d33f8af246993eab4bc4d (patch)
treeee108fce7337013453b6b9c5065ccd2e2b45acce /configure.in
parent5a99ade413b97a780758f5c8f927604ad6c8e57b (diff)
downloadbird-61fb537c6273c50deb7d33f8af246993eab4bc4d.tar
bird-61fb537c6273c50deb7d33f8af246993eab4bc4d.zip
Use `struct ip_mreqn' instead of `struct ip_mreq' for multicast
operations on 2.1/2.2 kernels. This allows passing of real interface indexes instead of referencing interfaces by their IP addresses which fails badly in presence of unnumbered interfaces. Unfortunately, this structure is not visible with glibc 2.0 as it provides its own networking headers :-( Both libc5 and glibc 2.1 should be OK.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2cf123a..a8ef734 100644
--- a/configure.in
+++ b/configure.in
@@ -109,6 +109,7 @@ BIRD_CHECK_INTEGERS
BIRD_CHECK_ENDIAN
BIRD_CHECK_STRUCT_ALIGN
BIRD_CHECK_TIME_T
+BIRD_CHECK_STRUCT_MREQN
if test "$enable_debug" = yes ; then
AC_DEFINE(PATH_CONFIG_DIR, ".")