summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Mares <mj@ucw.cz>2000-05-08 16:51:57 +0200
committerMartin Mares <mj@ucw.cz>2000-05-08 16:51:57 +0200
commit6b5ab87581ba496ad0a9c12ef66f1372e1459685 (patch)
tree4f00a1b1e9096bcf433db4aa27799581783ef5b7 /configure.in
parente48dae3ed70daf52ad93c4fdc73270ab1510661f (diff)
downloadbird-6b5ab87581ba496ad0a9c12ef66f1372e1459685.tar
bird-6b5ab87581ba496ad0a9c12ef66f1372e1459685.zip
Added `--disable-memcheck' switch which avoids linking of efence/dmalloc,
so that we can run in debugging mode with large routing tables.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index cd7fa18..6d58e7c 100644
--- a/configure.in
+++ b/configure.in
@@ -7,6 +7,7 @@ AC_INIT(conf/confbase.Y)
AC_CONFIG_AUX_DIR(tools)
AC_ARG_ENABLE(debug,[ --enable-debug enable internal debugging routines (default: disabled)],,enable_debug=no)
+AC_ARG_ENABLE(memcheck,[ --enable-memcheck check memory allocations when debugging (default: enabled)],,enable_memcheck=yes)
AC_ARG_ENABLE(warnings,[ --enable-warnings enable extra warnings (default: disabled)],,enable_warnings=no)
AC_ARG_ENABLE(client,[ --enable-client enable building of BIRD client (default: enabled)],,enable_client=yes)
AC_ARG_ENABLE(ipv6,[ --enable-ipv6 enable building of IPv6 version (default: disabled)],,enable_ipv6=no)
@@ -145,9 +146,11 @@ BIRD_CHECK_STRUCT_IP_MREQN
if test "$enable_debug" = yes ; then
AC_DEFINE(DEBUGGING)
- AC_CHECK_LIB(dmalloc, dmalloc_debug)
- if test $ac_cv_lib_dmalloc_dmalloc_debug != yes ; then
- AC_CHECK_LIB(efence, malloc)
+ if test "$enable_memcheck" = yes ; then
+ AC_CHECK_LIB(dmalloc, dmalloc_debug)
+ if test $ac_cv_lib_dmalloc_dmalloc_debug != yes ; then
+ AC_CHECK_LIB(efence, malloc)
+ fi
fi
fi