summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorOndrej Filip <feela@network.cz>2004-05-31 17:08:29 +0200
committerOndrej Filip <feela@network.cz>2004-05-31 17:08:29 +0200
commit6de62923120c1dba8461aed8aed95eff433fcf4a (patch)
tree630f0a01fa0ab034f40487091276eb3dd0db60df /configure.in
parent012279f395a7cb87a3085b6c4674777da7ee9661 (diff)
downloadbird-6de62923120c1dba8461aed8aed95eff433fcf4a.tar
bird-6de62923120c1dba8461aed8aed95eff433fcf4a.zip
Better readline checking.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c3d8ef6..c74ab38 100644
--- a/configure.in
+++ b/configure.in
@@ -185,8 +185,8 @@ if test "$enable_client" = yes ; then
AC_CHECK_LIB(termcap, tgetent, USE_TERMCAP_LIB=-ltermcap)))
AC_CHECK_LIB(readline, rl_callback_read_char, CLIENT_LIBS="-lreadline $CLIENT_LIBS $USE_TERMCAP_LIB",
AC_MSG_ERROR([[The client requires GNU readline library 2.1 or newer. Either install the library or use --disable-client to compile without the client.]]), $USE_TERMCAP_LIB)
- AC_CHECK_FUNCS(rl_crlf)
- AC_CHECK_FUNCS(rl_ding)
+ AC_CHECK_LIB(readline, rl_crlf, AC_DEFINE(HAVE_RL_CRLF),,$USE_TERMCAP_LIB)
+ AC_CHECK_LIB(readline, rl_ding, AC_DEFINE(HAVE_RL_DING),,$USE_TERMCAP_LIB)
fi
AC_SUBST(CLIENT)
AC_SUBST(CLIENT_LIBS)