summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Mares <mj@ucw.cz>1999-03-04 12:36:26 +0100
committerMartin Mares <mj@ucw.cz>1999-03-04 12:36:26 +0100
commit7a2105becdbadf20c1b4e4d2359e339c90610825 (patch)
tree524bc4947ec1938cd48e3ec6a44a9f66983f8e4b /configure.in
parentaa64578641c15b137172acc927d9d7af5914576b (diff)
downloadbird-7a2105becdbadf20c1b4e4d2359e339c90610825.tar
bird-7a2105becdbadf20c1b4e4d2359e339c90610825.zip
Use dmalloc instead of EFence when available (dmalloc has lot of improvements
over EFence and also hopefully smaller memory overhead, but sadly it's non-free for commercial use). If the DMALLOC_OPTIONS environment variable is not set, switch on `reasonable' checks by default. Also introduced mb_allocz() for cleared mb_alloc().
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0b46949..aa527a0 100644
--- a/configure.in
+++ b/configure.in
@@ -109,7 +109,10 @@ BIRD_CHECK_TIME_T
if test "$enable_debug" = yes ; then
AC_DEFINE(PATH_CONFIG_DIR, ".")
AC_DEFINE(DEBUGGING)
- AC_CHECK_LIB(efence, malloc)
+ AC_CHECK_LIB(dmalloc, dmalloc_debug)
+ if test $ac_cv_lib_dmalloc_dmalloc_debug != yes ; then
+ AC_CHECK_LIB(efence, malloc)
+ fi
else
AC_DEFINE_UNQUOTED(PATH_CONFIG_DIR, "$sysconfdir")
fi