summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Mares <mj@ucw.cz>2000-01-19 16:07:00 +0100
committerMartin Mares <mj@ucw.cz>2000-01-19 16:07:00 +0100
commit9fac310d1a4e46f4bcc70177e59cbf93763ef479 (patch)
tree7ad25775400768f05abbd8f004fb0ca80a5f60fe /configure.in
parentf50b9e48b93e3f69423a0e6e5fef273ba2022958 (diff)
downloadbird-9fac310d1a4e46f4bcc70177e59cbf93763ef479.tar
bird-9fac310d1a4e46f4bcc70177e59cbf93763ef479.zip
Put client on a stony ground. The whole client is going to be system-specific
(the current version UNIX-specific) anyway, so it's useless to try splitting it to sysdep and generic part. Instead of this, configure script decides (based on system type and user's wish) what (if any) client should be built and what autoconfiguration it requires. Also, the client provides its own die/bug/... functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5ef8212..1e1fdba 100644
--- a/configure.in
+++ b/configure.in
@@ -1,12 +1,13 @@
dnl ** This is a configure script template for BIRD
dnl ** Process it with autoconf to get ./configure
-dnl ** (c) 1999 Martin Mares <mj@ucw.cz>
+dnl ** (c) 1999--2000 Martin Mares <mj@ucw.cz>
AC_REVISION($Id$)
AC_INIT(conf/confbase.Y)
AC_CONFIG_AUX_DIR(tools)
AC_ARG_ENABLE(debug,[ --enable-debug enable internal debugging routines (default: enabled)],,enable_debug=yes)
+AC_ARG_ENABLE(client,[ --enable-client enable building of BIRD client (default: enabled)],,enable_client=yes)
AC_ARG_WITH(sysconfig,[ --with-sysconfig=FILE use specified BIRD system configuration file])
AC_ARG_WITH(protocols,[ --with-protocols=LIST include specified routing protocols (default: rip,static,pipe)],,[with_protocols="rip,static,pipe"])
AC_ARG_WITH(sysinclude,[ --with-sysinclude=PATH search for system includes on specified place])
@@ -133,6 +134,13 @@ else
AC_DEFINE_UNQUOTED(PATH_CONTROL_SOCKET_DIR, "$localstatedir")
fi
+if test "$enable_client" = yes ; then
+ CLIENT=client
+else
+ CLIENT=
+fi
+AC_SUBST(CLIENT)
+
mkdir -p $objdir/sysdep
AC_CONFIG_HEADER($objdir/sysdep/autoconf.h:sysdep/autoconf.h.in)
AC_OUTPUT_COMMANDS(,[CPP="$CPP" $srcdir/tools/mergedirs $srcdir $srcdir_rel $objdir $sysdep_dirs])
@@ -146,5 +154,6 @@ BIRD was configured with the following options:
System configuration: $sysdesc
Debugging: $enable_debug
Routing protocols: $protocols
+ Client: $enable_client
EOF
rm -f $objdir/.*-stamp