summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Mares <mj@ucw.cz>1999-05-21 16:09:06 +0200
committerMartin Mares <mj@ucw.cz>1999-05-21 16:09:06 +0200
commita07e9d82352d0060ff4f00aa8d0a2575cafc781a (patch)
tree3d427f0bef7649dc9c6cec9719d7fd1279e5b7e9 /configure.in
parent4f1a6d27b9a44f61329bc7b6779a0c645362e181 (diff)
downloadbird-a07e9d82352d0060ff4f00aa8d0a2575cafc781a.tar
bird-a07e9d82352d0060ff4f00aa8d0a2575cafc781a.zip
Added --with-sysinclude to allow explicitly setting where kernel includes
reside, so that you can easily switch between 2.0 and 2.2 ones. Check existence of <linux/rtnetlink.h> for linux-22 configs to make sure we're using the correct set of includes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 05cd381..4aaddf7 100644
--- a/configure.in
+++ b/configure.in
@@ -9,6 +9,7 @@ AC_CONFIG_AUX_DIR(tools)
AC_ARG_ENABLE(debug,[ --enable-debug enable internal debugging routines (default: enabled)],,enable_debug=yes)
AC_ARG_WITH(sysconfig,[ --with-sysconfig=FILE use specified BIRD system configuration file])
AC_ARG_WITH(protocols,[ --with-protocols=LIST include specified routing protocols (default: rip,static)],,[with_protocols="rip,static"])
+AC_ARG_WITH(sysinclude,[ --with-sysinclude=PATH search for system includes on specified place])
if test "$srcdir" = . ; then
# Building in current directory => create obj directory holding all objects
@@ -91,6 +92,9 @@ AC_MSG_CHECKING([what CFLAGS should we use])
if test "$ac_test_CFLAGS" != set ; then
CFLAGS="$CFLAGS -Wall -W -Wstrict-prototypes -Wno-unused -Wno-parentheses"
fi
+if test "$with_sysinclude" != no -a -n "$with_sysinclude"; then
+ CPPFLAGS="$CPPFLAGS -I$with_sysinclude"
+fi
AC_MSG_RESULT($CFLAGS)
AC_PROG_CPP
@@ -103,6 +107,11 @@ if test -z "$FLEX" -o -z "$BISON" -o -z "$M4" ; then
AC_MSG_ERROR([Some tools required for building BIRD are missing.])
fi
+case $sysdesc in
+ */linux-22*) AC_CHECK_HEADER(linux/rtnetlink.h,,[AC_MSG_ERROR([Appropriate version of Linux kernel headers not found.])])
+ ;;
+esac
+
AC_CHECK_HEADER(syslog.h, [AC_DEFINE(HAVE_SYSLOG)])
BIRD_CHECK_INTEGERS