summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorOndrej Zajicek <santiago@crfreenet.org>2010-03-24 16:39:18 +0100
committerOndrej Zajicek <santiago@crfreenet.org>2010-03-24 16:39:18 +0100
commitb1c030b0ba59eed6da5271ed592d6b93ed088518 (patch)
tree360bdf883e05208e63c9ef494b62ac49c377dc71 /configure.in
parent4d9a0d1f02134235bf686caf49af44232590c456 (diff)
downloadbird-b1c030b0ba59eed6da5271ed592d6b93ed088518.tar
bird-b1c030b0ba59eed6da5271ed592d6b93ed088518.zip
Adds autoconf test for -Wno-pointer-sign compliler option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index c931c18..3c988b1 100644
--- a/configure.in
+++ b/configure.in
@@ -55,17 +55,28 @@ AC_SEARCH_LIBS(clock_gettime,[c rt posix4])
AC_CANONICAL_HOST
-AC_MSG_CHECKING([what CFLAGS should we use])
+# Store this value because ac_test_CFLAGS is overwritten by AC_PROG_CC
if test "$ac_test_CFLAGS" != set ; then
- CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wno-pointer-sign -Wno-parentheses"
+ bird_cflags_default=yes
fi
-AC_MSG_RESULT($CFLAGS)
AC_PROG_CC
if test -z "$GCC" ; then
AC_MSG_ERROR([This program requires the GNU C Compiler.])
fi
+AC_MSG_CHECKING([what CFLAGS should we use])
+if test "$bird_cflags_default" == yes ; then
+ BIRD_CHECK_GCC_OPTIONS
+
+ CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wno-parentheses"
+ if test "$bird_cv_c_option_no_pointer_sign" == yes ; then
+ CFLAGS="$CFLAGS -Wno-pointer-sign"
+ fi
+fi
+AC_MSG_RESULT($CFLAGS)
+
+
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_RANLIB