summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorOndrej Zajicek <santiago@crfreenet.org>2009-10-27 22:25:36 +0100
committerOndrej Zajicek <santiago@crfreenet.org>2009-10-27 22:25:36 +0100
commite6ff7a08e4e7808e1175c3c3bc830d93c0454b19 (patch)
tree25182d2c3970feb974544e33f9c0ac73c6fe14cd /configure.in
parentbff74c7aa3ce4d407cb18b48c9df7b670c3c7a3d (diff)
downloadbird-e6ff7a08e4e7808e1175c3c3bc830d93c0454b19.tar
bird-e6ff7a08e4e7808e1175c3c3bc830d93c0454b19.zip
Replaces local endianity testing macro with the common one.
That makes it easier to integrate BIRD to crosscompiling buildsystems.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 8d519fd..429b22f 100644
--- a/configure.in
+++ b/configure.in
@@ -179,8 +179,10 @@ AC_TRY_COMPILE([#include <sys/types.h>
AC_DEFINE(HAVE_SIN_LEN,,sin_len)],
AC_MSG_RESULT(no))
+AC_C_BIGENDIAN([AC_DEFINE(CPU_BIG_ENDIAN)], [AC_DEFINE(CPU_LITTLE_ENDIAN)],
+ [AC_MSG_ERROR([Cannot determine CPU endianity.])])
+
BIRD_CHECK_INTEGERS
-BIRD_CHECK_ENDIAN
BIRD_CHECK_STRUCT_ALIGN
BIRD_CHECK_TIME_T
BIRD_CHECK_STRUCT_IP_MREQN