summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorOndrej Zajicek <santiago@crfreenet.org>2010-02-21 14:34:53 +0100
committerOndrej Zajicek <santiago@crfreenet.org>2010-02-21 14:34:53 +0100
commite81b440f6878605edd19ed62441648ac71260881 (patch)
treebec78543f4a89096ac22e850dbb814a3f75d119a /configure.in
parent9e43ccf07b96597ef098955a07383d826938cd2d (diff)
downloadbird-e81b440f6878605edd19ed62441648ac71260881.tar
bird-e81b440f6878605edd19ed62441648ac71260881.zip
Fix configure to enable warnings and fix most of them.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 6 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index ec2417b..c931c18 100644
--- a/configure.in
+++ b/configure.in
@@ -8,7 +8,6 @@ AC_CONFIG_AUX_DIR(tools)
AC_ARG_ENABLE(debug,[ --enable-debug enable internal debugging routines (default: disabled)],,enable_debug=no)
AC_ARG_ENABLE(memcheck,[ --enable-memcheck check memory allocations when debugging (default: enabled)],,enable_memcheck=yes)
-AC_ARG_ENABLE(warnings,[ --enable-warnings enable extra warnings (default: disabled)],,enable_warnings=no)
AC_ARG_ENABLE(client,[ --enable-client enable building of BIRD client (default: enabled)],,enable_client=yes)
AC_ARG_ENABLE(ipv6,[ --enable-ipv6 enable building of IPv6 version (default: disabled)],,enable_ipv6=no)
AC_ARG_WITH(sysconfig,[ --with-sysconfig=FILE use specified BIRD system configuration file])
@@ -56,24 +55,17 @@ AC_SEARCH_LIBS(clock_gettime,[c rt posix4])
AC_CANONICAL_HOST
-AC_PROG_CC
-if test -z "$GCC" ; then
- AC_MSG_ERROR([This program requires the GNU C Compiler.])
- fi
AC_MSG_CHECKING([what CFLAGS should we use])
if test "$ac_test_CFLAGS" != set ; then
- if test "$enable_warnings" = yes ; then
- WARNS=" -Wmissing-prototypes -Wundef"
- else
- WARNS=" -Wno-unused"
- fi
- CFLAGS="$CFLAGS -Wall -W -Wstrict-prototypes -Wno-pointer-sign -Wno-parentheses$WARNS"
-fi
-if test "$with_sysinclude" != no -a -n "$with_sysinclude"; then
- CPPFLAGS="$CPPFLAGS -I$with_sysinclude"
+ CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wno-pointer-sign -Wno-parentheses"
fi
AC_MSG_RESULT($CFLAGS)
+AC_PROG_CC
+if test -z "$GCC" ; then
+ AC_MSG_ERROR([This program requires the GNU C Compiler.])
+fi
+
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_RANLIB