summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Mares <mj@ucw.cz>2000-05-08 16:19:47 +0200
committerMartin Mares <mj@ucw.cz>2000-05-08 16:19:47 +0200
commitf9254d2349c7e2e3c110f7850e402d1c11624940 (patch)
treeaf9ae9a6b2ca0107f4a02929fc9e332558b9e0ad /configure.in
parent0bf7386b33fecac40be43f8db5b0ba0356123fd2 (diff)
downloadbird-f9254d2349c7e2e3c110f7850e402d1c11624940.tar
bird-f9254d2349c7e2e3c110f7850e402d1c11624940.zip
Autoconf is *evil*. The sysconfdir and similar variables are unusable in
C includes as they contain substitutions specific to make. Worked around by creating sysconf/paths.h which is created from the Makefile instead of by the configure script.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 0 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index b197c3d..cd7fa18 100644
--- a/configure.in
+++ b/configure.in
@@ -144,16 +144,11 @@ BIRD_CHECK_TIME_T
BIRD_CHECK_STRUCT_IP_MREQN
if test "$enable_debug" = yes ; then
- AC_DEFINE(PATH_CONFIG_DIR, ".")
- AC_DEFINE(PATH_CONTROL_SOCKET_DIR, ".")
AC_DEFINE(DEBUGGING)
AC_CHECK_LIB(dmalloc, dmalloc_debug)
if test $ac_cv_lib_dmalloc_dmalloc_debug != yes ; then
AC_CHECK_LIB(efence, malloc)
fi
-else
- AC_DEFINE_UNQUOTED(PATH_CONFIG_DIR, "$sysconfdir")
- AC_DEFINE_UNQUOTED(PATH_CONTROL_SOCKET_DIR, "$localstatedir")
fi
CLIENT=