summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0b46949..aa527a0 100644
--- a/configure.in
+++ b/configure.in
@@ -109,7 +109,10 @@ BIRD_CHECK_TIME_T
if test "$enable_debug" = yes ; then
AC_DEFINE(PATH_CONFIG_DIR, ".")
AC_DEFINE(DEBUGGING)
- AC_CHECK_LIB(efence, malloc)
+ AC_CHECK_LIB(dmalloc, dmalloc_debug)
+ if test $ac_cv_lib_dmalloc_dmalloc_debug != yes ; then
+ AC_CHECK_LIB(efence, malloc)
+ fi
else
AC_DEFINE_UNQUOTED(PATH_CONFIG_DIR, "$sysconfdir")
fi