summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2009-11-27 20:47:58 +0100
committerMatthias Schiffer <matthias@gamezock.de>2009-11-27 20:47:58 +0100
commit59360094e5ac1ddeb5eda365ac4ccf765786635f (patch)
tree4ddf107804febdfb4550a0e616a07945c65c5e96 /CMakeLists.txt
downloadc3d-59360094e5ac1ddeb5eda365ac4ccf765786635f.tar
c3d-59360094e5ac1ddeb5eda365ac4ccf765786635f.zip
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..50e80ca
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 2.6)
+project(C3D)
+
+find_package(OpenGL REQUIRED)
+
+include_directories(${OPENGL_INCLUDE_DIR})
+
+add_executable(c3d
+ BSPGenerator.cpp BSPGenerator.h
+ BSPTree.h
+ Color.h
+ Cuboid.cpp Cuboid.h
+ DisplayClass.cpp DisplayClass.h
+ gl.h
+ main.cpp
+ Matrix.h
+ Triangle.h
+ Vector.h
+ Vertex.h
+)
+target_link_libraries(c3d ${OPENGL_LIBRARIES})