summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..2c11d3b
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+vala_precompile(TEST_C
+ Test.vala
+PACKAGES
+ gee-1.0
+ erl_interface
+CUSTOM_VAPIS
+ ${eva_BINARY_DIR}/src/eva.vapi
+)
+
+include_directories(BEFORE ${eva_BINARY_DIR}/src)
+add_executable(eva-test ${TEST_C})
+target_link_libraries(eva-test eva)