summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2010-06-26 17:28:49 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2010-06-26 17:28:49 +0200
commita6a3c416c77d383f00a723ceb4545e89a2334923 (patch)
tree4f99cde816967947bf4cd5dc3d631aa04df50202 /test/CMakeLists.txt
downloadeva-a6a3c416c77d383f00a723ceb4545e89a2334923.tar
eva-a6a3c416c77d383f00a723ceb4545e89a2334923.zip
Put together cmake build
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..2c11d3b
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+vala_precompile(TEST_C
+ Test.vala
+PACKAGES
+ gee-1.0
+ erl_interface
+CUSTOM_VAPIS
+ ${eva_BINARY_DIR}/src/eva.vapi
+)
+
+include_directories(BEFORE ${eva_BINARY_DIR}/src)
+add_executable(eva-test ${TEST_C})
+target_link_libraries(eva-test eva)