summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 16:01:16 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 16:01:16 +0100
commit4496be6e29732189769b78f63e491dacb23c961b (patch)
tree5882550f4cf9b516fdd613bbaf4535a7f59d981a /CMakeLists.txt
parent20a95ef2731ce21acfe5c1ba97b40001217b0216 (diff)
downloadfastd-4496be6e29732189769b78f63e491dacb23c961b.tar
fastd-4496be6e29732189769b78f63e491dacb23c961b.zip
Convert ghash to the new crypto algorithm scheme
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 2 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 12daafa..70a17c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,7 +33,8 @@ set(WITH_CMDLINE_COMMANDS TRUE CACHE BOOL "Include support for setting handler s
set(WITH_CIPHER_AES128_CTR TRUE CACHE BOOL "Include the AES128-CTR cipher algorithm")
set(WITH_CIPHER_AES128_CTR_NACL TRUE CACHE BOOL "Include the AES128-CTR implementation from the NaCl library")
-set(WITH_CRYPTO_GHASH_BUILTIN TRUE CACHE BOOL "Include the built-in GHASH implementation")
+set(WITH_MAC_GHASH TRUE CACHE BOOL "Include the GHASH MAC algorithm")
+set(WITH_MAC_GHASH_BUILTIN TRUE CACHE BOOL "Include the built-in GHASH implementation")
set(WITH_METHOD_XSALSA20_POLY1305 TRUE CACHE BOOL "Include xsalsa20-poly1305 method")
set(WITH_METHOD_GENERIC_GCM TRUE CACHE BOOL "Include generic gcm method")
@@ -44,25 +45,9 @@ set(USE_LIBSODIUM FALSE CACHE BOOL "Use libsodium instead of NaCl")
set(MAX_CONFIG_DEPTH 10 CACHE STRING "Maximum config include depth")
-if(WITH_CRYPTO_GHASH_BUILTIN)
- set(WITH_CRYPTO_GHASH TRUE)
-endif(WITH_CRYPTO_GHASH_BUILTIN)
-
-
# Ensure the value is numeric
math(EXPR MAX_CONFIG_DEPTH_NUM ${MAX_CONFIG_DEPTH})
-set(USE_CRYPTO_GHASH FALSE)
-
-if(WITH_METHOD_AES128_GCM)
- set(USE_CRYPTO_GHASH TRUE)
-endif(WITH_METHOD_AES128_GCM)
-
-
-if(USE_CRYPTO_GHASH AND NOT WITH_CRYPTO_GHASH)
- MESSAGE(FATAL_ERROR "No GHASH implementation was selected, but a selected method needs it.")
-endif(USE_CRYPTO_GHASH AND NOT WITH_CRYPTO_GHASH)
-
find_package(BISON 2.5 REQUIRED)