summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 17:42:30 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-11-02 17:47:20 +0100
commit38b7d50694b4a9929cc0d5bca884a52d5aeaa8a4 (patch)
tree8d5c690296423b9261a864c1b8cfde06b85d9d9a /src/CMakeLists.txt
parentcd47acaf3cc874f8d26acca56fa6cef6110d946d (diff)
downloadfastd-38b7d50694b4a9929cc0d5bca884a52d5aeaa8a4.tar
fastd-38b7d50694b4a9929cc0d5bca884a52d5aeaa8a4.zip
Separate cmake files
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dc5b8a1..6b4dc92 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -5,24 +5,15 @@ include_directories(${FASTD_SOURCE_DIR} ${FASTD_BINARY_DIR}/src ${CAP_INCLUDE_D
link_directories(${UECC_LIBRARY_DIRS} ${NACL_LIBRARY_DIRS})
+include(generate_version)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/fastd_config.h.in ${CMAKE_CURRENT_BINARY_DIR}/fastd_config.h)
+
add_subdirectory(protocols)
add_subdirectory(methods)
add_subdirectory(crypto)
-add_custom_target(
- version
- COMMAND echo "#ifndef _FASTD_FASTD_VERSION_H_" > ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h.new
- COMMAND echo "#define _FASTD_FASTD_VERSION_H_" >> ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h.new
- COMMAND sh -c "echo \"#define FASTD_VERSION \\\"$(git --git-dir=./.git describe --dirty 2>/dev/null || echo ${FASTD_VERSION})\\\"\"" >> ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h.new
- COMMAND echo "#endif /* _FASTD_FASTD_VERSION_H_ */" >> ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h.new
- COMMAND cmp -s ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h.new ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h && rm ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h.new || mv ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h.new ${CMAKE_CURRENT_BINARY_DIR}/fastd_version.h
- WORKING_DIRECTORY "${FASTD_SOURCE_DIR}"
- VERBATIM
-)
-
BISON_TARGET(fastd_config_parse config.y ${CMAKE_CURRENT_BINARY_DIR}/config.yy.c)
add_executable(fastd