summaryrefslogtreecommitdiffstats
path: root/src/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 18:27:10 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2013-10-28 18:31:02 +0100
commitfc8c8d82f05911836208cc9169e103d5578ffd70 (patch)
tree06aad5eebfa87982ae95a76bb5644161fc73c6df /src/protocols/CMakeLists.txt
parent095ca93d81cfae0fcb137919231810577c556404 (diff)
downloadfastd-fc8c8d82f05911836208cc9169e103d5578ffd70.tar
fastd-fc8c8d82f05911836208cc9169e103d5578ffd70.zip
Unify duplicate code in xsalsa20-poly1305 and aes128-gcm methods
Diffstat (limited to 'src/protocols/CMakeLists.txt')
-rw-r--r--src/protocols/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/protocols/CMakeLists.txt b/src/protocols/CMakeLists.txt
index f033d32..60bfa8e 100644
--- a/src/protocols/CMakeLists.txt
+++ b/src/protocols/CMakeLists.txt
@@ -1,10 +1,10 @@
set(PROTOCOLS ec25519_fhmqvc)
-set(PROTOCOL_OBJECTS "")
+set(PROTOCOL_SOURCES "")
foreach(protocol ${PROTOCOLS})
add_subdirectory(${protocol})
- list(APPEND PROTOCOL_OBJECTS $<TARGET_OBJECTS:protocol_${protocol}>)
+ list(APPEND PROTOCOL_SOURCES $<TARGET_OBJECTS:protocol_${protocol}>)
endforeach(protocol)
-set(PROTOCOL_OBJECTS "${PROTOCOL_OBJECTS}" PARENT_SCOPE)
+set(PROTOCOL_SOURCES "${PROTOCOL_SOURCES}" PARENT_SCOPE)