summaryrefslogtreecommitdiffstats
path: root/ffd/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2012-09-07 03:50:44 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2012-09-07 03:50:44 +0200
commitf22dc0880f1b9348dc8c056cba0bbce223a39e62 (patch)
treed88090edf80436cef422214cda7b61f172358825 /ffd/CMakeLists.txt
parent5998b096b969cb931e5e3d7850415be1c70f122c (diff)
downloadffd-f22dc0880f1b9348dc8c056cba0bbce223a39e62.tar
ffd-f22dc0880f1b9348dc8c056cba0bbce223a39e62.zip
Basic code for the data distribution daemon
Diffstat (limited to 'ffd/CMakeLists.txt')
-rw-r--r--ffd/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/ffd/CMakeLists.txt b/ffd/CMakeLists.txt
new file mode 100644
index 0000000..d2d2a52
--- /dev/null
+++ b/ffd/CMakeLists.txt
@@ -0,0 +1,10 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${FFD_BINARY_DIR} ${CMAKE_CURRENT_BINARY_DIR})
+
+add_executable(ffd
+ ffd.c
+ netif.c
+ util.c
+)
+target_link_libraries(ffd rt)
+
+install(TARGETS ffd RUNTIME DESTINATION sbin)