summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2014-03-18 16:56:06 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2014-03-18 16:56:06 +0100
commit0587bef25eb23f58aad1cd0b39d6bcb2dd074578 (patch)
treeef87590bd512577ffe30bcd3d9b4d06edd24b4d1 /src/CMakeLists.txt
parent7efd6c82cb359b5220134f5e65828a671f4e8b1c (diff)
downloadbabel-0587bef25eb23f58aad1cd0b39d6bcb2dd074578.tar
babel-0587bef25eb23f58aad1cd0b39d6bcb2dd074578.zip
Compile options, -Wextra fixes
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 64cda12..f8c0a8a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,4 +1,5 @@
include_directories(${GMRF_INCLUDE_DIR})
+set_directory_properties(PROPERTIES COMPILE_DEFINITIONS _GNU_SOURCE)
add_library(mmss_proto_babel MODULE
babel.c
@@ -9,4 +10,4 @@ add_library(mmss_proto_babel MODULE
tlv_types.c
)
target_link_libraries(mmss_proto_babel ${MMSS_PROTOCOL_LIB})
-set_target_properties(mmss_proto_babel PROPERTIES LINK_FLAGS "-Wl,--undefined=mmss_protocol_info")
+set_target_properties(mmss_proto_babel PROPERTIES COMPILE_FLAGS "-std=c99 -Wall" LINK_FLAGS "-Wl,--undefined=mmss_protocol_info")