summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 64cda12..f8c0a8a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,4 +1,5 @@
include_directories(${GMRF_INCLUDE_DIR})
+set_directory_properties(PROPERTIES COMPILE_DEFINITIONS _GNU_SOURCE)
add_library(mmss_proto_babel MODULE
babel.c
@@ -9,4 +10,4 @@ add_library(mmss_proto_babel MODULE
tlv_types.c
)
target_link_libraries(mmss_proto_babel ${MMSS_PROTOCOL_LIB})
-set_target_properties(mmss_proto_babel PROPERTIES LINK_FLAGS "-Wl,--undefined=mmss_protocol_info")
+set_target_properties(mmss_proto_babel PROPERTIES COMPILE_FLAGS "-std=c99 -Wall" LINK_FLAGS "-Wl,--undefined=mmss_protocol_info")