summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2019-05-31 18:42:01 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2019-05-31 18:42:01 +0200
commitbcef77a7fb3b73d2a2fbcea51012014b62755bb5 (patch)
tree3a5935014a6a2569e592f40086f7858d1207c66c /meson.build
parent44cb17317c40fa9d39b3402f0826006f20387be5 (diff)
downloadneco-bcef77a7fb3b73d2a2fbcea51012014b62755bb5.tar
neco-bcef77a7fb3b73d2a2fbcea51012014b62755bb5.zip
Switch to a JSON-based config format
We can get rid of a lot of code by ditching out INI format parser. We also remove the support for "subtype" and "generator" templates for now; rather than implementing this in NeCo itself, templates could be implemented as a Lua DSL later.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d7a554a..0cbd657 100644
--- a/meson.build
+++ b/meson.build
@@ -3,6 +3,7 @@ project('neco', 'c', default_options : ['c_std=gnu11'])
cc = meson.get_compiler('c')
libubox_dep = cc.find_library('ubox')
+libjson_c_dep = dependency('json-c', method : 'pkg-config')
libmnl_dep = dependency('libmnl', method : 'pkg-config')
subdir('src')