summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2009-12-16 14:58:56 +0100
committerMatthias Schiffer <matthias@gamezock.de>2009-12-16 14:58:56 +0100
commitea08fea654b4702a77f623b74137fabc7d6800d8 (patch)
tree7550e20704ee9a93e6b1ea95d72563250956ac17 /CMakeLists.txt
parenta407f8b9edbc7a6e865b2daf65b2a6cd10edd2d7 (diff)
downloadzoom++-ea08fea654b4702a77f623b74137fabc7d6800d8.tar
zoom++-ea08fea654b4702a77f623b74137fabc7d6800d8.zip
Use perspective projection matrix without far clipping plane.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a57452..af00fd4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,11 @@ project(ZOOM)
set(CMAKE_MODULE_PATH ${ZOOM_SOURCE_DIR})
find_package(Boost REQUIRED)
-find_package(OpenGL REQUIRED)
+find_package(OpenGL)
+IF (NOT OPENGL_FOUND)
+ MESSAGE(FATAL_ERROR "Could not find OpenGL")
+ENDIF (NOT OPENGL_FOUND)
+
find_package(GLEW REQUIRED)
find_package(GLPng REQUIRED)
find_package(LibXml2 REQUIRED)