summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a57452..af00fd4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,11 @@ project(ZOOM)
set(CMAKE_MODULE_PATH ${ZOOM_SOURCE_DIR})
find_package(Boost REQUIRED)
-find_package(OpenGL REQUIRED)
+find_package(OpenGL)
+IF (NOT OPENGL_FOUND)
+ MESSAGE(FATAL_ERROR "Could not find OpenGL")
+ENDIF (NOT OPENGL_FOUND)
+
find_package(GLEW REQUIRED)
find_package(GLPng REQUIRED)
find_package(LibXml2 REQUIRED)