summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 305c938..7a57452 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,17 +11,4 @@ find_package(LibXml2 REQUIRED)
include_directories(${Boost_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR} ${GLEW_INCLUDE_DIR} ${GLPNG_INCLUDE_DIR} ${LIBXML2_INCLUDE_DIR})
-add_executable(zoom
- BSPTree.cpp BSPTree.h
- Game.cpp Game.h
- config.h
- gl.h
- Level.cpp Level.h
- Renderer.cpp Renderer.h
- Shader.cpp Shader.h
- Texture.cpp Texture.h
- Triangle.h
- zoom.cpp
-)
-
-target_link_libraries(zoom ${Boost_LIBRARIES} ${OPENGL_LIBRARIES} ${GLEW_LIBRARY} ${GLPNG_LIBRARY} ${LIBXML2_LIBRARIES})
+add_subdirectory(src)