summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <matthias@gamezock.de>2010-01-07 07:03:58 +0100
committerMatthias Schiffer <matthias@gamezock.de>2010-01-07 07:03:58 +0100
commite0cb6bd23b21f126bde42f74f4b1a798c3e15b0f (patch)
treebc9aba37b5b4c6edeb8725720c2ebfe5e80643ab /src/CMakeLists.txt
parentd71148392055eec06460fa24e3747d2c55d96b38 (diff)
downloadzoomedit-e0cb6bd23b21f126bde42f74f4b1a798c3e15b0f.tar
zoomedit-e0cb6bd23b21f126bde42f74f4b1a798c3e15b0f.zip
Major cleanup
Much better now!
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..cdf2748
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,23 @@
+add_executable(zoomedit
+ Data/Gate.cpp Data/Gate.h
+ Data/Info.cpp Data/Info.h
+ Data/Level.cpp Data/Level.h
+ Data/Room.cpp Data/Room.h
+ Data/TexCoords.h
+ Data/Texture.cpp Data/Texture.h
+ Data/Triangle.cpp Data/Triangle.h
+
+ Gui/AspectFrame.h
+ Gui/RenderArea.cpp Gui/RenderArea.h
+ Gui/Window.cpp Gui/Window.h
+
+ Math/Triangle2D.cpp Math/Triangle2D.h
+
+ View/MapView.cpp View/MapView.h
+ View/TopView.cpp View/TopView.h
+ View/View.h
+
+ Instance.cpp Instance.h
+ zoomedit.cpp
+)
+target_link_libraries(zoomedit ${OPENGL_gl_LIBRARY} ${XMLPP_LIBRARIES} ${GTKMM_LIBRARIES} ${GTKGLEXT_LIBRARIES})