summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..cdf2748
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,23 @@
+add_executable(zoomedit
+ Data/Gate.cpp Data/Gate.h
+ Data/Info.cpp Data/Info.h
+ Data/Level.cpp Data/Level.h
+ Data/Room.cpp Data/Room.h
+ Data/TexCoords.h
+ Data/Texture.cpp Data/Texture.h
+ Data/Triangle.cpp Data/Triangle.h
+
+ Gui/AspectFrame.h
+ Gui/RenderArea.cpp Gui/RenderArea.h
+ Gui/Window.cpp Gui/Window.h
+
+ Math/Triangle2D.cpp Math/Triangle2D.h
+
+ View/MapView.cpp View/MapView.h
+ View/TopView.cpp View/TopView.h
+ View/View.h
+
+ Instance.cpp Instance.h
+ zoomedit.cpp
+)
+target_link_libraries(zoomedit ${OPENGL_gl_LIBRARY} ${XMLPP_LIBRARIES} ${GTKMM_LIBRARIES} ${GTKGLEXT_LIBRARIES})