summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-11-28 21:08:58 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-11-30 09:53:44 +0100
commit501c6d70a6a7357652e2a4fb1ad5856d90bde29b (patch)
tree8a5625ba6403b4caea9389b75565e344c86c54ee /CMakeLists.txt
parent52ea48e47a75e98b33a95a237dbf84f3eb0c59c4 (diff)
downloadunitd-501c6d70a6a7357652e2a4fb1ad5856d90bde29b.tar
unitd-501c6d70a6a7357652e2a4fb1ad5856d90bde29b.zip
Remove trigger and watch support, clean up service handling
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7419ca5..26f7854 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,10 +8,9 @@ SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
SET(SOURCES procd.c signal.c watchdog.c state.c askconsole.c ubus.c system.c early.c
- service/service.c service/instance.c service/trigger.c service/watch.c
- utils/utils.c)
+ service/service.c service/instance.c utils/utils.c)
-SET(LIBS ubox ubus json-c blobmsg_json json_script)
+SET(LIBS ubox ubus json-c blobmsg_json)
IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -g3)