summaryrefslogtreecommitdiffstats
path: root/upgraded/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-11-28 14:58:01 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-11-30 09:53:36 +0100
commit13590ca98ac2fd4939b683adbfdd63392b559f3f (patch)
tree37a267d3ac4ca067fea1d2a1789c1a055ed7b707 /upgraded/CMakeLists.txt
parent890ac34c460fbb753bd4303b201d11aebd27a570 (diff)
downloadunitd-13590ca98ac2fd4939b683adbfdd63392b559f3f.tar
unitd-13590ca98ac2fd4939b683adbfdd63392b559f3f.zip
Strip down procd to the necessary code, update copyright
Diffstat (limited to 'upgraded/CMakeLists.txt')
-rw-r--r--upgraded/CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/upgraded/CMakeLists.txt b/upgraded/CMakeLists.txt
deleted file mode 100644
index 093dba2..0000000
--- a/upgraded/CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-cmake_minimum_required(VERSION 2.6)
-
-PROJECT(upgraded C)
-ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
-set(CMAKE_EXE_LINKER_FLAGS "-static -fPIC")
-set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
-set(CMAKE_EXE_LINK_DYNAMIC_C_FLAGS)
-set(CMAKE_EXE_LINK_DYNAMIC_CXX_FLAGS)
-set(CMAKE_SHARED_LIBRARY_C_FLAGS)
-set(CMAKE_SHARED_LIBRARY_CXX_FLAGS)
-set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS)
-set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS)
-ADD_EXECUTABLE(upgraded upgraded.c ../watchdog.c)
-TARGET_LINK_LIBRARIES(upgraded ubox rt -lc -lgcc_pic)
-INSTALL(TARGETS upgraded
- RUNTIME DESTINATION sbin
-)