summaryrefslogtreecommitdiffstats
path: root/crates/rebel-parse/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/rebel-parse/Cargo.toml')
-rw-r--r--crates/rebel-parse/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/crates/rebel-parse/Cargo.toml b/crates/rebel-parse/Cargo.toml
new file mode 100644
index 0000000..d116736
--- /dev/null
+++ b/crates/rebel-parse/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "rebel-parse"
+version = "0.1.0"
+authors = ["Matthias Schiffer <mschiffer@universe-factory.net>"]
+license = "MIT"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+derive-into-owned = { git = "https://github.com/neocturne/derive-into-owned.git", branch = "more-types" }
+peg = "0.8.3"
+phf = { version = "0.11.2", features = ["macros"] }
+rebel-common = { path = "../rebel-common" }
+rustc-hash = "1.1.0"
+
+[dev-dependencies]
+clap = { version = "4.0.0", features = ["derive"] }
+divan = "0.1.14"
+
+[[bench]]
+name = "recipe"
+harness = false