summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2015-03-25 23:52:08 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2015-03-25 23:52:08 +0100
commit09972613c44cf9968afc17d7294aa5e77fc29b9c (patch)
tree3eb8dcd846f58b781a271c1f5c39f1dc27e06c18 /CMakeLists.txt
downloadsolar-09972613c44cf9968afc17d7294aa5e77fc29b9c.tar
solar-09972613c44cf9968afc17d7294aa5e77fc29b9c.zip
Some initial work
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..8e04b01
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.8.3)
+project(SOLAR CXX)
+
+
+add_executable(solar
+ lex.cpp
+ parser.cpp
+ solar.cpp
+ state.cpp
+)
+set_target_properties(solar PROPERTIES COMPILE_FLAGS "-std=c++11 -Wall")