summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-07-20 23:49:37 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-07-20 23:49:51 +0200
commit22ae19b43a6893f30600a43e2fc98ca62cda6676 (patch)
tree762cadcf20d479977f0e383c5563700031cdccc0 /src/CMakeLists.txt
parentc082c8800c42d6f9da98ed985babc8ad2c2265a7 (diff)
downloadMinedMap-22ae19b43a6893f30600a43e2fc98ca62cda6676.tar
MinedMap-22ae19b43a6893f30600a43e2fc98ca62cda6676.zip
Add regiondump tool
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 070d419..4e4d23f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -26,3 +26,13 @@ add_executable(nbtdump
)
set_target_properties(nbtdump PROPERTIES COMPILE_FLAGS "-std=c++11 -Wall")
target_link_libraries(nbtdump ${ZLIB_LIBRARIES})
+
+add_executable(regiondump
+ regiondump.cpp
+ GZip.cpp
+ NBT/Tag.cpp
+ World/ChunkData.cpp
+ World/Region.cpp
+)
+set_target_properties(regiondump PROPERTIES COMPILE_FLAGS "-std=c++11 -Wall")
+target_link_libraries(regiondump ${ZLIB_LIBRARIES})